make legal-info: fails with OVERRIDE_SRCDIR
authorStephan Hoffmann <sho@relinux.de>
Mon, 3 Dec 2012 00:05:51 +0000 (00:05 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 5 Dec 2012 19:29:37 +0000 (11:29 -0800)
There is a check for OVERRIDE_SRCDIR in pkg-generic.mk that is
supposed to produce a warning when OVERRIDE_SRCDIR is active.
This does not work and instead the whole make terminates with
an error message.

This patch changes the check for active OVERRIDE_SRCDIR so that
it works as expected.

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-generic.mk

index 6fcd359ee4403f81b3eaedecb2a8972f8e9b5bbd..fc05dc66bb331523f797e96bbee8787eebf4fc7d 100644 (file)
@@ -477,7 +477,7 @@ ifneq ($(call qstrip,$$($(2)_SOURCE)),)
 ifeq ($$($(2)_SITE_METHOD),local)
 # Packages without a tarball: don't save and warn
        @$(call legal-warning-pkg-savednothing,$$($(2)_RAWNAME),local)
-else ifeq ($$($(2)_SITE_METHOD),override)
+else ifneq ($$($(2)_OVERRIDE_SRCDIR),)
        @$(call legal-warning-pkg-savednothing,$$($(2)_RAWNAME),override)
 else
 # Other packages