package: add 'pv' (Pipe-Viewer)
authorRoeland Van Praet <roelvp@mind.be>
Fri, 7 Oct 2011 07:04:26 +0000 (09:04 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 7 Oct 2011 08:19:54 +0000 (10:19 +0200)
Signed-off-by: Roeland Van Praet <roelvp@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/pv/Config.in [new file with mode: 0644]
package/pv/pv-1.2.0-fixld.patch [new file with mode: 0644]
package/pv/pv.mk [new file with mode: 0644]

index 173e19d461c27987ea9f22468b55fd99da8a26ad..904ebb6e9a520120c97b99b279ab82d94eb71909 100644 (file)
@@ -31,6 +31,7 @@ source "package/oprofile/Config.in"
 source "package/strace/Config.in"
 source "package/whetstone/Config.in"
 source "package/valgrind/Config.in"
+source "package/pv/Config.in"
 endmenu
 
 menu "Development tools"
diff --git a/package/pv/Config.in b/package/pv/Config.in
new file mode 100644 (file)
index 0000000..671f78e
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PV
+       bool "pv"
+       help
+         Pipe Viewer - is a terminal-based tool for
+         monitoring the progress of data through a
+         pipeline.
+
+         http://www.ivarch.com/programs/pv.shtml
diff --git a/package/pv/pv-1.2.0-fixld.patch b/package/pv/pv-1.2.0-fixld.patch
new file mode 100644 (file)
index 0000000..9df279d
--- /dev/null
@@ -0,0 +1,21 @@
+[PATCH] fix linker variable
+
+The linker variable LD was always set to 'ld' instead of the value from
+the environment. This breaks any linking, especially when dealing with
+a cross-compiler toolchain.
+The fix takes the CC variable and changes the 'gcc' extension to 'ld'.
+
+Signed-off-by: Roeland Van Praet <roelvp@mind.be>
+---
+diff -ruN a/autoconf/make/vars.mk b/autoconf/make/vars.mk
+--- a/autoconf/make/vars.mk    2010-03-11 00:43:19.000000000 +0100
++++ b/autoconf/make/vars.mk    2011-10-06 15:47:18.000000000 +0200
+@@ -30,7 +30,7 @@
+ @SET_MAKE@
+ SHELL = /bin/sh
+ CC = @CC@
+-LD = ld
++LD = $(CC:gcc=ld)
+ DO_GZIP = @DO_GZIP@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
diff --git a/package/pv/pv.mk b/package/pv/pv.mk
new file mode 100644 (file)
index 0000000..5f15f5b
--- /dev/null
@@ -0,0 +1,11 @@
+#######################
+#
+# pv - Pipe Viewer
+#
+#######################
+
+PV_VERSION = 1.2.0
+PV_SOURCE = pv-$(PV_VERSION).tar.bz2
+PV_SITE = http://pipeviewer.googlecode.com/files
+
+$(eval $(call AUTOTARGETS))