package/pkg-generic.mk: move pkg_size_{before, after} and check_bin_arch functions
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 30 Apr 2020 09:52:44 +0000 (11:52 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 23 Jul 2020 20:48:51 +0000 (22:48 +0200)
These functions are no longer using the GLOBAL_INSTRUMENTATION_HOOKS
mechanism, so it doesn't make much sense for them to be in the section
of pkg-generic.mk related to those hooks.

Move them to the "Helper functions" section.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-generic.mk

index 659b8e5661acc1e46f1fb304801f0d8fc4bb0c97..c63807047b2903da76f30342756e1752e6cde46c 100644 (file)
@@ -55,39 +55,6 @@ define step_time
 endef
 GLOBAL_INSTRUMENTATION_HOOKS += step_time
 
-# Hooks to collect statistics about installed files
-
-# $(1): base directory to search in
-# $(2): suffix of file (optional)
-define pkg_size_before
-       cd $(1); \
-       LC_ALL=C find . -not -path './$(STAGING_SUBDIR)/*' \( -type f -o -type l \) -printf '%T@:%i:%#m:%y:%s,%p\n' \
-               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(2).before
-endef
-
-# $(1): base directory to search in
-# $(2): suffix of file (optional)
-define pkg_size_after
-       cd $(1); \
-       LC_ALL=C find . -not -path './$(STAGING_SUBDIR)/*' \( -type f -o -type l \) -printf '%T@:%i:%#m:%y:%s,%p\n' \
-               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(2).after
-       LC_ALL=C comm -13 \
-               $($(PKG)_DIR)/.files-list$(2).before \
-               $($(PKG)_DIR)/.files-list$(2).after \
-               | sed -r -e 's/^[^,]+/$($(PKG)_NAME)/' \
-               > $($(PKG)_DIR)/.files-list$(2).txt
-       rm -f $($(PKG)_DIR)/.files-list$(2).before
-       rm -f $($(PKG)_DIR)/.files-list$(2).after
-endef
-
-define check_bin_arch
-       support/scripts/check-bin-arch -p $($(PKG)_NAME) \
-               -l $($(PKG)_DIR)/.files-list.txt \
-               $(foreach i,$($(PKG)_BIN_ARCH_EXCLUDE),-i "$(i)") \
-               -r $(TARGET_READELF) \
-               -a $(BR2_READELF_ARCH_NAME)
-endef
-
 # This hook checks that host packages that need libraries that we build
 # have a proper DT_RPATH or DT_RUNPATH tag
 define check_host_rpath
@@ -135,6 +102,39 @@ define fixup-libtool-files
 endef
 endif
 
+# Functions to collect statistics about installed files
+
+# $(1): base directory to search in
+# $(2): suffix of file (optional)
+define pkg_size_before
+       cd $(1); \
+       LC_ALL=C find . -not -path './$(STAGING_SUBDIR)/*' \( -type f -o -type l \) -printf '%T@:%i:%#m:%y:%s,%p\n' \
+               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(2).before
+endef
+
+# $(1): base directory to search in
+# $(2): suffix of file (optional)
+define pkg_size_after
+       cd $(1); \
+       LC_ALL=C find . -not -path './$(STAGING_SUBDIR)/*' \( -type f -o -type l \) -printf '%T@:%i:%#m:%y:%s,%p\n' \
+               | LC_ALL=C sort > $($(PKG)_DIR)/.files-list$(2).after
+       LC_ALL=C comm -13 \
+               $($(PKG)_DIR)/.files-list$(2).before \
+               $($(PKG)_DIR)/.files-list$(2).after \
+               | sed -r -e 's/^[^,]+/$($(PKG)_NAME)/' \
+               > $($(PKG)_DIR)/.files-list$(2).txt
+       rm -f $($(PKG)_DIR)/.files-list$(2).before
+       rm -f $($(PKG)_DIR)/.files-list$(2).after
+endef
+
+define check_bin_arch
+       support/scripts/check-bin-arch -p $($(PKG)_NAME) \
+               -l $($(PKG)_DIR)/.files-list.txt \
+               $(foreach i,$($(PKG)_BIN_ARCH_EXCLUDE),-i "$(i)") \
+               -r $(TARGET_READELF) \
+               -a $(BR2_READELF_ARCH_NAME)
+endef
+
 ################################################################################
 # Implicit targets -- produce a stamp file for each step of a package build
 ################################################################################