gob2: remove deprecated target package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Jan 2015 14:30:18 +0000 (11:30 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 25 Jan 2015 23:02:58 +0000 (00:02 +0100)
It's been deprecated for a year now so remove the target variant.

Also rename patch to new naming convention.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/gob2/0001-dont-include-from-prefix.patch [new file with mode: 0644]
package/gob2/Config.in [deleted file]
package/gob2/gob2-01-dont-include-from-prefix.patch [deleted file]
package/gob2/gob2.mk

index 9bd2fde838ccf1c8f6a92e73767513d3aed72bd1..50591af17331dff327c58797547d2c863ac78d4b 100644 (file)
@@ -102,6 +102,14 @@ endif
 
 comment "Legacy options removed in 2015.02"
 
+config BR2_PACKAGE_GOB2
+       bool "gob2 target package removed"
+       select BR2_LEGACY
+       help
+         The gob2 target package has been removed, it's been
+         deprecated for some time now and was essentially useless
+         without a target toolchain.
+
 config BR2_PACKAGE_DISTCC
        bool "distcc target package removed"
        select BR2_LEGACY
index f04464e19c8174da986a9d6f9e41f3bb26085b10..d3d2f39934506ba1381e42b950e4a0171cc8cf48 100644 (file)
@@ -246,7 +246,6 @@ comment "X applications"
        source "package/feh/Config.in"
        source "package/freerdp/Config.in"
        source "package/gmpc/Config.in"
-       source "package/gob2/Config.in"
        source "package/gqview/Config.in"
        source "package/gtkperf/Config.in"
        source "package/leafpad/Config.in"
diff --git a/package/gob2/0001-dont-include-from-prefix.patch b/package/gob2/0001-dont-include-from-prefix.patch
new file mode 100644 (file)
index 0000000..1b603d7
--- /dev/null
@@ -0,0 +1,40 @@
+[PATCH] Don't search $prefix/include for header files
+
+Don't add $prefix/include to the header file search path, as that breaks
+cross compilation (build $prefix/include isn't the same as target
+$prefix/include).
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ src/Makefile.am |    3 +--
+ src/Makefile.in |    3 +--
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+Index: gob2-2.0.15/src/Makefile.am
+===================================================================
+--- gob2-2.0.15.orig/src/Makefile.am
++++ gob2-2.0.15/src/Makefile.am
+@@ -17,8 +17,7 @@ INCLUDES = \
+       -I$(top_builddir)       \
+       -I$(top_builddir)/src   \
+       -I$(top_srcdir)         \
+-      -I$(top_srcdir)/src     \
+-      -I$(includedir)
++      -I$(top_srcdir)/src
+ if NOINSTGOB
+ noinst_PROGRAMS = @NOINSTGOB@
+Index: gob2-2.0.15/src/Makefile.in
+===================================================================
+--- gob2-2.0.15.orig/src/Makefile.in
++++ gob2-2.0.15/src/Makefile.in
+@@ -193,8 +193,7 @@ INCLUDES = \
+       -I$(top_builddir)       \
+       -I$(top_builddir)/src   \
+       -I$(top_srcdir)         \
+-      -I$(top_srcdir)/src     \
+-      -I$(includedir)
++      -I$(top_srcdir)/src
+ @NOINSTGOB_TRUE@noinst_PROGRAMS = @NOINSTGOB@
+ @NOINSTGOB_FALSE@bin_PROGRAMS = @INSTGOB@
diff --git a/package/gob2/Config.in b/package/gob2/Config.in
deleted file mode 100644 (file)
index bd9ba1f..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-config BR2_PACKAGE_GOB2
-       bool "gob2"
-       depends on BR2_USE_WCHAR # glib2
-       depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
-       depends on BR2_USE_MMU # bison, glib2
-       select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_FLEX
-       select BR2_PACKAGE_BISON
-       # development tool, useless on the target
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       help
-         GOB (GTK+ Object Builder) is a preprocessor which simplifies
-         the writing of GObjects in C.
-
-         http://www.jirka.org/gob.html
-
-comment "gob2 needs a toolchain w/ wchar"
-       depends on BR2_USE_MMU
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/gob2/gob2-01-dont-include-from-prefix.patch b/package/gob2/gob2-01-dont-include-from-prefix.patch
deleted file mode 100644 (file)
index 1b603d7..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-[PATCH] Don't search $prefix/include for header files
-
-Don't add $prefix/include to the header file search path, as that breaks
-cross compilation (build $prefix/include isn't the same as target
-$prefix/include).
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- src/Makefile.am |    3 +--
- src/Makefile.in |    3 +--
- 2 files changed, 2 insertions(+), 4 deletions(-)
-
-Index: gob2-2.0.15/src/Makefile.am
-===================================================================
---- gob2-2.0.15.orig/src/Makefile.am
-+++ gob2-2.0.15/src/Makefile.am
-@@ -17,8 +17,7 @@ INCLUDES = \
-       -I$(top_builddir)       \
-       -I$(top_builddir)/src   \
-       -I$(top_srcdir)         \
--      -I$(top_srcdir)/src     \
--      -I$(includedir)
-+      -I$(top_srcdir)/src
- if NOINSTGOB
- noinst_PROGRAMS = @NOINSTGOB@
-Index: gob2-2.0.15/src/Makefile.in
-===================================================================
---- gob2-2.0.15.orig/src/Makefile.in
-+++ gob2-2.0.15/src/Makefile.in
-@@ -193,8 +193,7 @@ INCLUDES = \
-       -I$(top_builddir)       \
-       -I$(top_builddir)/src   \
-       -I$(top_srcdir)         \
--      -I$(top_srcdir)/src     \
--      -I$(includedir)
-+      -I$(top_srcdir)/src
- @NOINSTGOB_TRUE@noinst_PROGRAMS = @NOINSTGOB@
- @NOINSTGOB_FALSE@bin_PROGRAMS = @INSTGOB@
index e4f1396c9825de22958d75073b2f572275dc22e8..04d02e115c43a7a8c77b2fbe2e306078459e9410 100644 (file)
@@ -7,10 +7,8 @@
 GOB2_VERSION = 2.0.20
 GOB2_SOURCE = gob2-$(GOB2_VERSION).tar.xz
 GOB2_SITE = http://ftp.5z.com/pub/gob
-GOB2_DEPENDENCIES = libglib2 flex bison host-pkgconf host-flex
 HOST_GOB2_DEPENDENCIES = host-bison host-flex host-libglib2
 
-$(eval $(autotools-package))
 $(eval $(host-autotools-package))
 
 # gob2 for the host