package/minetest: add postgresql optional dependency
authorRomain Naour <romain.naour@gmail.com>
Thu, 13 Jul 2017 12:40:48 +0000 (14:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 15:19:32 +0000 (17:19 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/minetest/minetest.mk

index 44a28ce2389ccbb9b1d70781385f12dcbda2f4f2..ba0bf240915229e94c0565b833be6ac273a4776d 100644 (file)
@@ -16,7 +16,6 @@ MINETEST_CONF_OPTS = \
        -DENABLE_GLES=OFF \
        -DENABLE_LUAJIT=ON \
        -DENABLE_CURSES=OFF \
-       -DENABLE_POSTGRESQL=OFF \
        -DENABLE_LEVELDB=OFF \
        -DENABLE_REDIS=OFF \
        -DENABLE_SPATIAL=OFF \
@@ -58,6 +57,13 @@ else
 MINETEST_CONF_OPTS += -DENABLE_CURL=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
+MINETEST_DEPENDENCIES += postgresql
+MINETEST_CONF_OPTS += -DENABLE_POSTGRESQL=ON
+else
+MINETEST_CONF_OPTS += -DENABLE_POSTGRESQL=OFF
+endif
+
 ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
 MINETEST_DEPENDENCIES += $(TARGET_NLS_DEPENDENCIES)
 MINETEST_CONF_OPTS += -DENABLE_GETTEXT=ON