package/libglu: needs host-pkgconf
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 13 Sep 2017 18:45:42 +0000 (20:45 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 12:36:11 +0000 (14:36 +0200)
Fix build error

>>> libglu 9.0.0 Autoreconfiguring
configure.ac:50: error: Could not locate the pkg-config autoconf macros.
  These are usually located in /usr/share/aclocal/pkg.m4. If your macros
  are in a different location, try setting the environment variable
  ACLOCAL="aclocal -I/other/macro/dir" before running autoreconf.
configure.ac:50: the top level
autom4te: /home/buildroot/br4/output/host/bin/m4 failed with exit status: 1

using this defconfig

BR2_TOOLCHAIN_BUILDROOT_GLIBC=y
BR2_TOOLCHAIN_BUILDROOT_CXX=y
BR2_PACKAGE_XORG7=y
BR2_PACKAGE_XSERVER_XORG_SERVER=y
BR2_PACKAGE_NVIDIA_DRIVER=y
BR2_PACKAGE_LIBGLU=y

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libglu/libglu.mk

index 038d281c59d68c654df0d2cb31cb5cf8bf7a64cf..0e5242f85eb04c36349c5663acbb2c705c7a03c5 100644 (file)
@@ -12,6 +12,6 @@ LIBGLU_LICENSE_FILES = include/GL/glu.h
 LIBGLU_INSTALL_STAGING = YES
 # upstream does not distribute a autoconf´ed configure script
 LIBGLU_AUTORECONF = YES
-LIBGLU_DEPENDENCIES = libgl
+LIBGLU_DEPENDENCIES = libgl host-pkgconf
 
 $(eval $(autotools-package))