toolchain-external: remove support for 'Sourcery CodeBench MIPS 2011.03'
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Dec 2012 13:23:23 +0000 (13:23 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 Dec 2012 08:23:05 +0000 (09:23 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index e28da870ed7b7d49fb7fbda876eff5eac0820fd8..4150a0a3fa358e437c94c77e66f63581053b12c9 100644 (file)
@@ -328,56 +328,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
            - MIPS32 little endian soft float uclibc
              Not usable in Buildroot yet.
 
-config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
-       bool "Sourcery CodeBench MIPS 2011.03"
-       depends on BR2_mips || BR2_mipsel
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_INSTALL_LIBSTDCPP
-       help
-         Sourcery CodeBench toolchain for the MIPS architecture, from
-         Mentor Graphics. It uses gcc 4.5.2, binutils 2.20.51, glibc
-         2.13, uClibc 0.9.30 and gdb 7.2.50, kernel headers
-         2.6.38. It has support for the following variants:
-           - MIPS32 O32 big endian glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-           - MIPS32 O32 little endian glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL
-           - MIPS32 big endian soft float glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-           - MIPS32 little endian soft float glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL
-           - MIPS32 big endian microMIPS glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -mips16
-           - MIPS32 little endian microMIPS glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
-           - MIPS32 big endian soft float microMIPS glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -mips16
-           - MIPS32 little endian soft float microMIPS glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
-           - MIPS32 big endian uclibc
-             Not usable in Buildroot yet.
-           - MIPS32 little endian uclibc
-             Not usable in Buildroot yet.
-           - MIPS32 big endian soft float uclibc
-             Not usable in Buildroot yet.
-           - MIPS32 little endian soft float uclibc
-             Not usable in Buildroot yet.
-
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103
        bool "Sourcery CodeBench PowerPC 2011.03"
        depends on BR2_powerpc
@@ -723,7 +673,6 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "aarch64-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_12_10
        default "microblazeel-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_V2
        default "microblaze-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2
-       default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201209
index ac639a74ce47bb7417896a98730c15aa66f80092..0724cb6b2267153b072a4f5e082686cc62747646 100644 (file)
@@ -193,9 +193,6 @@ TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.10-20121022_li
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11),y)
 TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.11/+download/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.11-20121123_linux.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103),y)
-TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package9469/public/mips-linux-gnu/
-TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.03-110-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109),y)
 TOOLCHAIN_EXTERNAL_SITE=https://sourcery.mentor.com/GNUToolchain/package9761/public/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.09-75-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2