libarchive: add selection of bsdcat
authorFrank Hunleth <fhunleth@troodon-software.com>
Tue, 26 Jul 2016 12:58:53 +0000 (08:58 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 27 Jul 2016 19:29:07 +0000 (21:29 +0200)
libarchive builds three commandline utilities: bsdtar, bsdcpio, and
bsdcat. This change adds control over the third utility to the list of
configuration options.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libarchive/Config.in
package/libarchive/libarchive.mk

index 81b5936ce87a89762a9575418e230f8d2ee71b79..fd429acb602336019f640cfe482cf827a20e930d 100644 (file)
@@ -24,4 +24,10 @@ config BR2_PACKAGE_LIBARCHIVE_BSDCPIO
          The 'bsdcpio' program is a different interface to
          essentially the same functionality as 'bsdtar'.
 
+config BR2_PACKAGE_LIBARCHIVE_BSDCAT
+       bool "bsdcat"
+       help
+         The 'bsdcat' program is a simple replacement tool
+         for zcat, bzcat, xzcat, and such.
+
 endif
index 30a231885a71087b80228a4c9010edb8f4444b70..bcf92f907a6c934b2fc01885dd7ecd38172b302a 100644 (file)
@@ -30,6 +30,16 @@ else
 LIBARCHIVE_CONF_OPTS += --disable-bsdcpio
 endif
 
+ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDCAT),y)
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBARCHIVE_CONF_OPTS += --enable-bsdcat=static
+else
+LIBARCHIVE_CONF_OPTS += --enable-bsdcat=shared
+endif
+else
+LIBARCHIVE_CONF_OPTS += --disable-bsdcat
+endif
+
 ifeq ($(BR2_PACKAGE_ACL),y)
 LIBARCHIVE_DEPENDENCIES += acl
 else
@@ -105,6 +115,7 @@ HOST_LIBARCHIVE_DEPENDENCIES = host-zlib
 HOST_LIBARCHIVE_CONF_OPTS = \
        --disable-bsdtar \
        --disable-bsdcpio \
+       --disable-bsdcat \
        --disable-acl \
        --disable-xattr \
        --without-bz2lib \