gpu-viv-bin-mx6q: use self-extractible helper
authorJérôme Pouiller <jezz@sysmic.org>
Tue, 9 Dec 2014 13:46:40 +0000 (14:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 19:10:43 +0000 (20:10 +0100)
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk

index aef16a30cd040895fed85edd89eaf2e22ae61683..bc44e384627ec5d039a385718bd648102eb5c628 100644 (file)
@@ -15,12 +15,7 @@ GPU_VIV_BIN_MX6Q_SOURCE = gpu-viv-bin-mx6q-$(GPU_VIV_BIN_MX6Q_VERSION).bin
 GPU_VIV_BIN_MX6Q_INSTALL_STAGING = YES
 
 GPU_VIV_BIN_MX6Q_LICENSE = Freescale Semiconductor Software License Agreement
-
-# No license file is included in the archive; we could extract it from
-# the self-extractor, but that's just too much effort.
-# This is a legal minefield: the EULA specifies that
-# the Board Support Package includes software and hardware (sic!)
-# for which a separate license is needed...
+GPU_VIV_BIN_MX6Q_LICENSE_FILES = EULA
 GPU_VIV_BIN_MX6Q_REDISTRIBUTE = NO
 
 GPU_VIV_BIN_MX6Q_PROVIDES = libegl libgles libopenvg
@@ -33,14 +28,8 @@ else
 GPU_VIV_BIN_MX6Q_LIB_TARGET = fb
 endif
 
-# The archive is a shell-self-extractor of a bzipped tar. It happens
-# to extract in the correct directory (gpu-viv-bin-mx6q-x.y.z)
-# The --force makes sure it doesn't fail if the source dir already exists.
-# The --auto-accept skips the license check - not needed for us
-# because we have legal-info.
 define GPU_VIV_BIN_MX6Q_EXTRACT_CMDS
-       (cd $(BUILD_DIR); \
-               sh $(DL_DIR)/$(GPU_VIV_BIN_MX6Q_SOURCE) --force --auto-accept)
+       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(GPU_VIV_BIN_MX6Q_SOURCE))
 endef
 
 # Instead of building, we fix up the inconsistencies that exist