package/kodi: add optional support for lcms2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 29 Apr 2017 08:37:46 +0000 (10:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Apr 2017 10:06:28 +0000 (12:06 +0200)
Support was added by https://github.com/xbmc/xbmc/pull/11846

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index 36d25637b72772c73db8d654e845819f1d81ae80..bf4ea01549ea98b705e1024716091cc9fc40f092 100644 (file)
@@ -151,6 +151,12 @@ config BR2_PACKAGE_KODI_LIBCEC
 comment "hdmi cec support needs udev /dev management"
        depends on !BR2_PACKAGE_HAS_UDEV
 
+config BR2_PACKAGE_KODI_LCMS2
+       bool "lcms2"
+       select BR2_PACKAGE_LCMS2
+       help
+         Enable color management support.
+
 config BR2_PACKAGE_KODI_LIRC
        bool "lirc"
        help
index 35219991331144a0547741da9a5551d577a44eb1..a4835f0207817e0f1bca57b67d49c56a226aa7d9 100644 (file)
@@ -289,6 +289,13 @@ else
 KODI_CONF_OPTS += -DENABLE_CEC=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_LCMS2),y)
+KODI_DEPENDENCIES += lcms2
+KODI_CONF_OPTS += -DENABLE_LCMS2=ON
+else
+KODI_CONF_OPTS += -DENABLE_LCMS2=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_KODI_LIRC),y)
 KODI_CONF_OPTS += -DENABLE_LIRC=ON
 else