ffmpeg: supports only the real OpenSSL, not LibreSSL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 16:46:40 +0000 (18:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 19:28:13 +0000 (21:28 +0200)
ffmpeg will not build with LibreSSL without patches, so let's support
only OpenSSL.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ffmpeg/ffmpeg.mk

index 801615c077fd0a5d738bbb3cf542928a6d140b42..1e758d3f8cb2c32d2a26fd0c29a8bd8e2db77b7e 100644 (file)
@@ -208,13 +208,13 @@ FFMPEG_CONF_OPTS += --enable-gnutls --disable-openssl
 FFMPEG_DEPENDENCIES += gnutls
 else
 FFMPEG_CONF_OPTS += --disable-gnutls
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
 # openssl isn't license compatible with GPL
 ifeq ($(BR2_PACKAGE_FFMPEG_GPL)x$(BR2_PACKAGE_FFMPEG_NONFREE),yx)
 FFMPEG_CONF_OPTS += --disable-openssl
 else
 FFMPEG_CONF_OPTS += --enable-openssl
-FFMPEG_DEPENDENCIES += openssl
+FFMPEG_DEPENDENCIES += libopenssl
 endif
 else
 FFMPEG_CONF_OPTS += --disable-openssl