package/cegui: disable Python SWIG extension modules unconditionally
authorBartosz Bilas <b.bilas@grinn-global.com>
Tue, 20 Jul 2021 18:10:48 +0000 (20:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 20 Jul 2021 18:26:19 +0000 (20:26 +0200)
It seems that Python SWIG extension module(s) are not compatible with
buildroot's SWIG version so disable them unconditionally to fix
the following build errors:

Fixes:
 - http://autobuild.buildroot.net/results/f80/f80ebdcbde08c13eddec9fadc39b9c2bd4b83e94//

  and more...

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cegui/cegui.mk

index 747ebbb953ddbc6696dbb106bf42bbbb0cdf2573..127d3b0fad497de3d3a7debdd1a2979e03d0d8ff 100644 (file)
@@ -16,7 +16,8 @@ CEGUI_CONF_OPTS = \
        -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
        -DCEGUI_USE_FRIBIDI=OFF \
        -DCEGUI_SAMPLES_ENABLED=OFF \
-       -DCEGUI_BUILD_APPLICATION_TEMPLATES=OFF
+       -DCEGUI_BUILD_APPLICATION_TEMPLATES=OFF \
+       -DCEGUI_BUILD_PYTHON_MODULES_SWIG=OFF
 CEGUI_DEPENDENCIES = glm \
        $(if $(BR2_PACKAGE_LIBGLFW),libglfw) \
        $(if $(BR2_PACKAGE_HAS_LIBGL),libgl) \