package/freerdp: fix pulseaudio support
authorAlexey Lukyanchuk <skif@skif-web.ru>
Tue, 5 Nov 2019 09:42:15 +0000 (12:42 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 5 Nov 2019 18:27:48 +0000 (19:27 +0100)
The name of the option to enable/disable support for pulseaudio has been
in flux in FreeRDP, soemtimes being WITH_PULSE, sometimes being the
erroneous WITH_PULSEAUDIO. Eventually, FreeRDP came to their feet, and
fixed it to WITH_PULSE everywhere.

Signed-off-by: Alexey Lukyanchuk <skif@skif-web.ru>
[yann.morin.1998@free.fr:
  - remove useless (obsolete) WITH_PULSEAUDIO
  - fix the else clause too
  - enhance commit log
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/freerdp/freerdp.mk

index 0f32ff4718f30b960cf8915c6fc155812e98613f..293b6b5c01f5e81b02a1cad8ec12c4366d225f16 100644 (file)
@@ -50,10 +50,10 @@ FREERDP_CONF_OPTS += -DWITH_ALSA=OFF
 endif
 
 ifeq ($(BR2_PACKAGE_PULSEAUDIO),y)
-FREERDP_CONF_OPTS += -DWITH_PULSEAUDIO=ON
+FREERDP_CONF_OPTS += -DWITH_PULSE=ON
 FREERDP_DEPENDENCIES += pulseaudio
 else
-FREERDP_CONF_OPTS += -DWITH_PULSEAUDIO=OFF
+FREERDP_CONF_OPTS += -DWITH_PULSE=OFF
 endif
 
 # For the systemd journal