aiccu: fix undefined reference to clock_* functions
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Tue, 14 Jan 2014 11:22:27 +0000 (11:22 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 14 Jan 2014 21:26:14 +0000 (22:26 +0100)
Since glibc 2.17 the clock_* suite functions are available directly in
the main C library. For previous versions we still need -lrt to link.

Upstream is aware of this problem.

Fixes:
   http://autobuild.buildroot.net/results/c11/c1182b00f9d968e587acba15af4af905b92227f5/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/aiccu/aiccu-0003-clock-suite-functions-fix.patch [new file with mode: 0644]

diff --git a/package/aiccu/aiccu-0003-clock-suite-functions-fix.patch b/package/aiccu/aiccu-0003-clock-suite-functions-fix.patch
new file mode 100644 (file)
index 0000000..365e72a
--- /dev/null
@@ -0,0 +1,18 @@
+aiccu: fix undefined reference to clock_* functions
+
+Since glibc 2.17 the clock_* suite functions are available directly in 
+the main C library. For previous versions we still need -lrt to link.
+
+Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
+
+--- aiccu/unix-console/Makefile.orig   2014-01-14 10:17:20.204602513 +0000
++++ aiccu/unix-console/Makefile        2014-01-14 10:17:31.435777359 +0000
+@@ -42,7 +42,7 @@ CFLAGS       += -D AICCU_CONSOLE
+ # Currently defaultly builds only on Linux, but other platforms might easily also support it
+ ifeq ($(shell uname | grep -c "Linux"),1)
+ CFLAGS        += -D AICCU_GNUTLS
+-LDFLAGS += -lgnutls
++LDFLAGS += -lgnutls -lrt
+ endif
+ # Linux