samba: update description and rename patches
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 2 Mar 2014 12:42:17 +0000 (09:42 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Mar 2014 14:20:40 +0000 (15:20 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/samba/Config.in
package/samba/samba-0001-fix-smbd-libs-avahi.patch [new file with mode: 0644]
package/samba/samba-0002-getaddrinfo.patch [new file with mode: 0644]
package/samba/samba-fix-smbd-libs-avahi.patch [deleted file]
package/samba/samba-getaddrinfo.patch [deleted file]

index 14690753612a0423def6bc1736e65804a8f263cc..c5b7e48da0ab9c8d96fd51b4549148bf0b3de8d3 100644 (file)
@@ -4,9 +4,9 @@ config BR2_PACKAGE_SAMBA
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_POPT
        help
-         Provides print services to all manner of SMB/CIFS clients,
-         including the numerous versions of Microsoft Windows
-         operating systems.
+         Provides secure, stable and fast file and print services
+         for all clients using the SMB/CIFS protocol, such as all
+         versions of DOS, Windows, OS/2, Linux and many others.
 
          http://www.samba.org/
 
diff --git a/package/samba/samba-0001-fix-smbd-libs-avahi.patch b/package/samba/samba-0001-fix-smbd-libs-avahi.patch
new file mode 100644 (file)
index 0000000..6624f57
--- /dev/null
@@ -0,0 +1,17 @@
+Expliticly link with -lpthread if smbd is compiled with
+avahi support. Otherwise the binary will fail to run.
+
+Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
+
+diff -Nura samba-3.6.16.orig/source3/Makefile.in samba-3.6.16/source3/Makefile.in
+--- samba-3.6.16.orig/source3/Makefile.in      2013-06-21 08:12:39.995871935 -0300
++++ samba-3.6.16/source3/Makefile.in   2013-06-21 08:13:17.778103805 -0300
+@@ -1783,7 +1783,7 @@
+               $(KRB5LIBS) $(DYNEXP) $(PRINT_LIBS) $(AUTH_LIBS) \
+               $(ACL_LIBS) $(PASSDB_LIBS) $(LIBS) $(DNSSD_LIBS) $(AVAHI_LIBS) \
+               $(POPT_LIBS) @SMBD_LIBS@ $(LIBTALLOC_LIBS) $(LIBTEVENT_LIBS) $(LIBTDB_LIBS) \
+-              $(LIBWBCLIENT_LIBS) $(ZLIB_LIBS)
++              $(LIBWBCLIENT_LIBS) $(ZLIB_LIBS) $(PTHREAD_LDFLAGS)
+
+ bin/nmbd@EXEEXT@: $(BINARY_PREREQS) $(NMBD_OBJ) @BUILD_POPT@ $(LIBTALLOC) $(LIBTEVENT) $(LIBTDB) $(LIBWBCLIENT)
+       @echo Linking $@
diff --git a/package/samba/samba-0002-getaddrinfo.patch b/package/samba/samba-0002-getaddrinfo.patch
new file mode 100644 (file)
index 0000000..df3570c
--- /dev/null
@@ -0,0 +1,20 @@
+Patch forward-ported from OpenWRT.
+Don't check for buggy getaddrinfo() assume it's safe if it's present.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura samba-3.6.8.orig/source3/configure samba-3.6.8/source3/configure
+--- samba-3.6.8.orig/source3/configure 2012-09-14 05:19:52.000000000 -0300
++++ samba-3.6.8/source3/configure      2012-09-25 20:31:57.861743235 -0300
+@@ -13269,10 +13269,7 @@
+       # see bug 5910, use our replacements if we detect
+       # a broken system.
+       if test "$cross_compiling" = yes; then :
+-  { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error $? "cannot run test program while cross compiling
+-See \`config.log' for more details" "$LINENO" 5; }
++              $as_echo "assuming valid getaddrinfo without bug 5910" >&2
+ else
+   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h.  */
diff --git a/package/samba/samba-fix-smbd-libs-avahi.patch b/package/samba/samba-fix-smbd-libs-avahi.patch
deleted file mode 100644 (file)
index 6624f57..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Expliticly link with -lpthread if smbd is compiled with
-avahi support. Otherwise the binary will fail to run.
-
-Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
-
-diff -Nura samba-3.6.16.orig/source3/Makefile.in samba-3.6.16/source3/Makefile.in
---- samba-3.6.16.orig/source3/Makefile.in      2013-06-21 08:12:39.995871935 -0300
-+++ samba-3.6.16/source3/Makefile.in   2013-06-21 08:13:17.778103805 -0300
-@@ -1783,7 +1783,7 @@
-               $(KRB5LIBS) $(DYNEXP) $(PRINT_LIBS) $(AUTH_LIBS) \
-               $(ACL_LIBS) $(PASSDB_LIBS) $(LIBS) $(DNSSD_LIBS) $(AVAHI_LIBS) \
-               $(POPT_LIBS) @SMBD_LIBS@ $(LIBTALLOC_LIBS) $(LIBTEVENT_LIBS) $(LIBTDB_LIBS) \
--              $(LIBWBCLIENT_LIBS) $(ZLIB_LIBS)
-+              $(LIBWBCLIENT_LIBS) $(ZLIB_LIBS) $(PTHREAD_LDFLAGS)
-
- bin/nmbd@EXEEXT@: $(BINARY_PREREQS) $(NMBD_OBJ) @BUILD_POPT@ $(LIBTALLOC) $(LIBTEVENT) $(LIBTDB) $(LIBWBCLIENT)
-       @echo Linking $@
diff --git a/package/samba/samba-getaddrinfo.patch b/package/samba/samba-getaddrinfo.patch
deleted file mode 100644 (file)
index df3570c..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-Patch forward-ported from OpenWRT.
-Don't check for buggy getaddrinfo() assume it's safe if it's present.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura samba-3.6.8.orig/source3/configure samba-3.6.8/source3/configure
---- samba-3.6.8.orig/source3/configure 2012-09-14 05:19:52.000000000 -0300
-+++ samba-3.6.8/source3/configure      2012-09-25 20:31:57.861743235 -0300
-@@ -13269,10 +13269,7 @@
-       # see bug 5910, use our replacements if we detect
-       # a broken system.
-       if test "$cross_compiling" = yes; then :
--  { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
--$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
--as_fn_error $? "cannot run test program while cross compiling
--See \`config.log' for more details" "$LINENO" 5; }
-+              $as_echo "assuming valid getaddrinfo without bug 5910" >&2
- else
-   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h.  */