u-boot: add AIS target format
authorVivien Didelot <vivien.didelot@savoirfairelinux.com>
Thu, 9 Aug 2012 18:11:09 +0000 (14:11 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Aug 2012 18:23:36 +0000 (20:23 +0200)
Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index afc2f917a01b54af80a1fbfa856c4237375d04ca..900fac7fc0b1f46456c5252234fb3d8650c2ce6d 100644 (file)
@@ -79,6 +79,14 @@ endif
 
 choice
        prompt "U-Boot binary format"
+       default BR2_TARGET_UBOOT_FORMAT_BIN
+
+config BR2_TARGET_UBOOT_FORMAT_AIS
+       bool "u-boot.ais"
+       help
+         AIS (Application Image Script) is a format defined by TI.
+         It is required to load code/data on OMAP-L1 processors.
+         u-boot.ais contains U-Boot with the SPL support.
 
 config BR2_TARGET_UBOOT_FORMAT_BIN
        bool "u-boot.bin"
index 9e03d6a61452c4a404743cf94d1bed6c6ad14c99..b61400e053e49d4e1ee0d42581432be601b95be3 100644 (file)
@@ -25,6 +25,9 @@ endif
 ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
 UBOOT_BIN          = u-boot.kwb
 UBOOT_MAKE_TARGET  = $(UBOOT_BIN)
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_AIS),y)
+UBOOT_BIN          = u-boot.ais
+UBOOT_MAKE_TARGET  = $(UBOOT_BIN)
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
 UBOOT_BIN          = u-boot.ldr
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)