package/kodi: enable optional vaapi support also for OpenGLES
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 20 Jun 2021 09:09:00 +0000 (11:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 18 Jul 2021 10:31:41 +0000 (12:31 +0200)
Upstream commit
https://github.com/xbmc/xbmc/commit/c638987dd8181765f975763cb643d6869a3f661b

removed the dependency to x11 support in libva keeping only libdrm as
dependency. This commit will enable the usage of libva with Kodi's
OpenGLES render system.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/kodi/Config.in
package/kodi/kodi.mk

index 1049d7af3ca3c4c13db70d57d6e0302dc2fb3546..56b018a30c667e0d5956fe5c4d43d5486ce8814b 100644 (file)
@@ -146,6 +146,14 @@ endif
 
 comment "Legacy options removed in 2021.08"
 
+config BR2_PACKAGE_KODI_LIBVA
+       bool "kodi option to add libva support removed"
+       select BR2_LEGACY
+       help
+         Kodi still has support for libva if the package is enabled but
+         the kodi-specific dependencies limiting libva support to non-
+         OPENGLES platforms were removed including this option.
+
 config BR2_PACKAGE_PHP_EXT_XMLRPC
        bool "PHP XMLRPC extension removed"
        select BR2_LEGACY
index f4cfc6380cf89e8ea4722811c225666a61ddc373..f702ae841a86cb1d34e7e6ab340aa9cc13ac483a 100644 (file)
@@ -238,24 +238,6 @@ config BR2_PACKAGE_KODI_LIBUSB
        help
          Enable libusb support.
 
-config BR2_PACKAGE_KODI_LIBVA
-       bool "va"
-       depends on \
-               BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_GBM || \
-               BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_WAYLAND || \
-               (BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_X11 && \
-                       BR2_PACKAGE_KODI_RENDER_SYSTEM_GL)
-       select BR2_PACKAGE_LIBVA
-       help
-         Enable libva support.
-
-comment "libva support needs platform 'gbm', 'Wayland' or 'X11/OpenGL'"
-       depends on \
-               !BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_GBM && \
-               !BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_WAYLAND && \
-               (!BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_X11 || \
-                       !BR2_PACKAGE_KODI_RENDER_SYSTEM_GL)
-
 config BR2_PACKAGE_KODI_LIBVDPAU
        bool "vdpau"
        depends on BR2_PACKAGE_KODI_PLATFORM_X11 && \
index a5c9db1d7e7dbe121984e4bd7eb19cb39afc0392..6f020b58b899a1ff1c4962fb8c5a07badca7b4c3 100644 (file)
@@ -315,9 +315,8 @@ ifeq ($(BR2_PACKAGE_LIRC_TOOLS),y)
 KODI_DEPENDENCIES += lirc-tools
 endif
 
-# kodi needs libva & libva-glx
-ifeq ($(BR2_PACKAGE_KODI_LIBVA)$(BR2_PACKAGE_MESA3D_DRI_DRIVER),yy)
-KODI_DEPENDENCIES += mesa3d libva
+ifeq ($(BR2_PACKAGE_LIBVA),y)
+KODI_DEPENDENCIES += libva
 KODI_CONF_OPTS += -DENABLE_VAAPI=ON
 else
 KODI_CONF_OPTS += -DENABLE_VAAPI=OFF