linux: bump default kernel to version 3.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 24 Oct 2011 14:54:03 +0000 (11:54 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 24 Oct 2011 15:49:13 +0000 (17:49 +0200)
Bump default kernel vesion to 3.1 to match headers.
Also implement downloads for 3.x series kernels.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/Config.in
linux/linux.mk

index 56552867fb721437b1d44913c8732a738e762d72..774aaf818c6db90f48ae56dc5c35a21e49d8fffc 100644 (file)
@@ -19,10 +19,10 @@ if BR2_LINUX_KERNEL
 #
 choice
        prompt "Kernel version"
-       default BR2_LINUX_KERNEL_2_6_39
+       default BR2_LINUX_KERNEL_3_1
 
-config BR2_LINUX_KERNEL_2_6_39
-       bool "2.6.39.4"
+config BR2_LINUX_KERNEL_3_1
+       bool "3.1"
 
 config BR2_LINUX_KERNEL_SAME_AS_HEADERS
        bool "Same as toolchain kernel headers"
@@ -58,7 +58,7 @@ endchoice
 config BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE
        string "Kernel version"
        depends on BR2_LINUX_KERNEL_CUSTOM_VERSION
-       default "2.6.39.4"
+       default "3.1"
 
 config BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION
        string "URL of custom kernel tarball"
@@ -74,7 +74,7 @@ config BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION
 
 config BR2_LINUX_KERNEL_VERSION
        string
-       default "2.6.39.4" if BR2_LINUX_KERNEL_2_6_39
+       default "3.1" if BR2_LINUX_KERNEL_3_1
        default BR2_DEFAULT_KERNEL_HEADERS if BR2_LINUX_KERNEL_SAME_AS_HEADERS
        default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE if BR2_LINUX_KERNEL_CUSTOM_VERSION
        default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
index 99f464966ace4c2fcb2532bdaa2f6c7f25223032..6b6fd5c4ae4e6705e05505ac385f066d5011f40f 100644 (file)
@@ -18,9 +18,11 @@ LINUX_SOURCE = linux-$(LINUX_VERSION).tar.bz2
 # In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
 # to use the $(word) function. We support versions such as 3.1,
 # 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.
-LINUX_VERSION_MAJOR = $(word 1,$(subst ., ,$(subst -, ,$(LINUX_VERSION))))
-LINUX_VERSION_MINOR = $(word 2,$(subst ., ,$(subst -, ,$(LINUX_VERSION))))
-LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v$(LINUX_VERSION_MAJOR).$(LINUX_VERSION_MINOR)/
+ifeq ($(findstring x2.6.,x$(LINUX_VERSION)),x2.6.)
+LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v2.6/
+else
+LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v3.x/
+endif
 # release candidates are in testing/ subdir
 ifneq ($(findstring -rc,$(LINUX_VERSION)),)
 LINUX_SITE := $(LINUX_SITE)testing/