package/firejail: remove broken package
authorRomain Naour <romain.naour@gmail.com>
Mon, 29 May 2017 19:58:11 +0000 (21:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 May 2017 20:16:17 +0000 (22:16 +0200)
firejail has been marked as broken since 3ad100fdcbf6e2bf850b4b2f528c87c74f7c93ff

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Chris Frederick <chrisf@cdf123.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/firejail/Config.in [deleted file]
package/firejail/firejail.hash [deleted file]
package/firejail/firejail.mk [deleted file]

index cd1efef15f2d9dbc058059722e8d1a4c93af0b9f..4936b81bd638278d74aa3adc4a2e56df8ca1cc41 100644 (file)
@@ -322,9 +322,6 @@ F:  package/libdvbsi/
 F:     package/libsvg/
 F:     package/libsvg-cairo/
 
-N:     Chris Frederick <chrisf@cdf123.net>
-F:     package/firejail/
-
 N:     Chris Packham <judge.packham@gmail.com>
 F:     package/eventlog/
 F:     package/micropython/
index 9da2c4366e3122dfb4f2eb35ea2337b971e9fd98..43d75a9c783a3ffb8d6e1fa43b26c0f714f5eaba 100644 (file)
@@ -1810,7 +1810,6 @@ menu "System tools"
        source "package/efibootmgr/Config.in"
        source "package/efivar/Config.in"
        source "package/emlog/Config.in"
-       source "package/firejail/Config.in"
        source "package/ftop/Config.in"
        source "package/getent/Config.in"
        source "package/htop/Config.in"
diff --git a/package/firejail/Config.in b/package/firejail/Config.in
deleted file mode 100644 (file)
index 764217b..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-config BR2_PACKAGE_FIREJAIL
-       bool "firejail"
-       depends on BROKEN # does not cross-compile at all
-       depends on BR2_USE_MMU # fork()
-       depends on BR2_TOOLCHAIN_HAS_THREADS
-       # uClibc: error: ‘EM_ARM’ undeclared
-       depends on !BR2_TOOLCHAIN_USES_UCLIBC
-       help
-         Firejail is a SUID program that reduces the risk of security
-         breaches by restricting the running environment of untrusted
-         applications using Linux namespaces and seccomp-bpf. It
-         allows a process and all its descendants to have their own
-         private view of the globally shared kernel resources, such
-         as the network stack, process table, mount table.
-
-         https://firejail.wordpress.com/
-
-comment "firejail needs a glibc or musl toolchain w/ threads"
-       depends on BR2_USE_MMU
-       depends on BROKEN
-       depends on BR2_TOOLCHAIN_USES_UCLIBC || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/firejail/firejail.hash b/package/firejail/firejail.hash
deleted file mode 100644 (file)
index 0cb86b4..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-# From https://sourceforge.net/projects/firejail/files/firejail/
-md5 7e6dca7202b1d70105b39646755cc620 firejail-0.9.44.8.tar.xz
-sha1 019423df0aee84d474f9fcd1f6a871a2fe8aa9a5 firejail-0.9.44.8.tar.xz
diff --git a/package/firejail/firejail.mk b/package/firejail/firejail.mk
deleted file mode 100644 (file)
index 858f547..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-################################################################################
-#
-# firejail
-#
-################################################################################
-
-FIREJAIL_VERSION = 0.9.44.8
-FIREJAIL_SITE = http://download.sourceforge.net/firejail
-FIREJAIL_SOURCE = firejail-$(FIREJAIL_VERSION).tar.xz
-FIREJAIL_LICENSE = GPL-2.0+
-FIREJAIL_LICENSE_FILES = COPYING
-
-FIREJAIL_CONF_OPTS = \
-       --enable-bind \
-       --enable-file-transfer \
-       --enable-network \
-       --enable-seccomp \
-       --enable-userns
-
-ifeq ($(BR2_PACKAGE_BUSYBOX),y)
-FIREJAIL_CONF_OPTS += --enable-busybox-workaround
-endif
-
-define FIREJAIL_PERMISSIONS
-       /usr/bin/firejail f 4755 0 0 - - - - -
-endef
-
-$(eval $(autotools-package))