bind: fix build failure for static+openssl
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 5 May 2013 10:54:11 +0000 (10:54 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 5 May 2013 20:57:54 +0000 (22:57 +0200)
Bind just links to openssl libraries without checking it's dependencies.
This works when doing shared builds since the linker picks the deps up,
but fails badly on static builds.
So just define LIBS="-lz" when openssl is enabled. Fixes:
http://autobuild.buildroot.net/results/a9a166f932e0b6727ae8e470ce748418797875b9/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bind/bind.mk

index 8a66534ebcb5bbe8df8827e565d9c9e60e09656c..f6895945a50d5c8aea90dc57edc8031cf83bf242 100644 (file)
@@ -30,7 +30,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
        BIND_DEPENDENCIES += openssl
-       BIND_CONF_OPT += --with-openssl=$(STAGING_DIR)/usr
+       BIND_CONF_OPT += --with-openssl=$(STAGING_DIR)/usr LIBS="-lz"
 else
        BIND_CONF_OPT += --with-openssl=no
 endif