linux: strip installed modules
authorMike Frysinger <vapier@gentoo.org>
Wed, 17 Nov 2010 23:55:43 +0000 (18:55 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 24 Nov 2010 21:02:40 +0000 (22:02 +0100)
The installed kernel modules should have useless build cruft stripped out
of them.  On my system, a default build went from a very unreasonable 30MB
to a normal 3MB (on disk) and from 14MB to 3MB when compressed due to the
info stored in the kernel modules alone.

[Peter: don't hardcode binutils strip specific options]
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index ef130de8adf7f19afb1950bad63dbd13bbf791c3..cfaa316a8214e14f74e3346a22cd7061dbb459ff 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -418,6 +418,9 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
        rm -rf $(TARGET_DIR)/usr/share/gtk-doc
 endif
        find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
+       find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
+               xargs -r $(STRIPCMD) -R .comment -R .note -g --strip-unneeded
+
        mkdir -p $(TARGET_DIR)/etc
        # Mandatory configuration file and auxilliary cache directory
        # for recent versions of ldconfig