mysql: disable maintainer mode
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Apr 2014 12:48:23 +0000 (14:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Apr 2014 12:48:23 +0000 (14:48 +0200)
The maintainer mode enables additional gcc warnings, including
-Werror, which causes build failures with certain toolchains. Since we
generally don't enable -Werror in Buildroot, it doesn't make much
sense to have it enabled for MySQL.

Fixes:

  http://autobuild.buildroot.net/results/6b6/6b61f90d1a36ba43ff568933bb74975128380516/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mysql/mysql.mk

index 95b30b7011a132e93b7b1a9c39c1f0b1e50fe585..5b30d847581344e23d65ad933951ad7d5eedc5d6 100644 (file)
@@ -30,14 +30,16 @@ MYSQL_CONF_OPT = \
        --without-libedit \
        --without-readline \
        --with-low-memory \
-       --enable-thread-safe-client
+       --enable-thread-safe-client \
+       --disable-mysql-maintainer-mode
 
 ifeq ($(BR2_PACKAGE_MYSQL_SERVER),y)
 MYSQL_DEPENDENCIES += host-mysql host-bison
 HOST_MYSQL_DEPENDENCIES =
 
 HOST_MYSQL_CONF_OPT = \
-       --with-embedded-server
+       --with-embedded-server \
+       --disable-mysql-maintainer-mode
 
 MYSQL_CONF_OPT += \
        --disable-dependency-tracking \