qt5: Fix sporadic build failure during top-level parallel build
authorAndreas Naumann <anaumann@ultratronik.de>
Tue, 17 Aug 2021 08:39:19 +0000 (10:39 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 28 Aug 2021 20:17:31 +0000 (22:17 +0200)
When using top level parallel build, independent qt5 packages may be
built in parallel. Because of their staging dirs being hardlinked, they
all use the same qt.conf file to manipulate during configure, while
another qt5 package might already use it. This leads to weird build failures
because the folders qmake is using are diverted in erratic ways.
Fix this by actually recreating a non-shared qt.conf file for every package.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Reviewed-by: Herve Codina <herve.codina@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qt5/qt5.mk

index db6ccd2b42833ab6cd2650d789e3d279671b0e76..3ffb7b0063adeed18b93cb275599bd6a76b48002 100644 (file)
@@ -15,6 +15,7 @@ include $(sort $(wildcard package/qt5/*/*.mk))
 # compiled into the Qt library. We need it to make "qmake" relocatable and
 # tweak the per-package install pathes
 define QT5_INSTALL_QT_CONF
+       rm -f $(HOST_DIR)/bin/qt.conf
        sed -e "s|@@HOST_DIR@@|$(HOST_DIR)|" -e "s|@@STAGING_DIR@@|$(STAGING_DIR)|" \
                $(QT5BASE_PKGDIR)/qt.conf.in > $(HOST_DIR)/bin/qt.conf
 endef