collectd: add chrony plugin support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 22 Dec 2016 01:59:13 +0000 (22:59 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Dec 2016 21:33:29 +0000 (22:33 +0100)
Add explicit support for the new chrony dependency-less plugin.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/Config.in
package/collectd/collectd.mk

index 72e57931a59a435d69df36e993250917234d61d8..5e84aa5c5d132e09823ffa453e6af725dafc1092 100644 (file)
@@ -127,6 +127,11 @@ config BR2_PACKAGE_COLLECTD_CEPH
        help
          Statistics from the Ceph distributed storage system.
 
+config BR2_PACKAGE_COLLECTD_CHRONY
+       bool "chrony"
+       help
+         Collects NTP data from the chrony NTP server.
+
 config BR2_PACKAGE_COLLECTD_CGROUPS
        bool "cgroups"
        help
index 11685cd004a781809309869f5e491d73888b1dcd..5018fb062847ec3e5fa0317b07a3a4208bd0118e 100644 (file)
@@ -35,6 +35,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_BATTERY),--enable-battery,--disable-battery) \
        $(if $(BR2_PACKAGE_COLLECTD_BIND),--enable-bind,--disable-bind) \
        $(if $(BR2_PACKAGE_COLLECTD_CEPH),--enable-ceph,--disable-ceph) \
+       $(if $(BR2_PACKAGE_COLLECTD_CHRONY),--enable-chrony,--disable-chrony) \
        $(if $(BR2_PACKAGE_COLLECTD_CGROUPS),--enable-cgroups,--disable-cgroups) \
        $(if $(BR2_PACKAGE_COLLECTD_CONNTRACK),--enable-conntrack,--disable-conntrack) \
        $(if $(BR2_PACKAGE_COLLECTD_CONTEXTSWITCH),--enable-contextswitch,--disable-contextswitch) \