package/mesa3d: Add option to build OSMesa
authorAndré Hentschel <nerv@dawncrow.de>
Sat, 3 Oct 2015 17:21:55 +0000 (19:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 13 Oct 2015 19:15:44 +0000 (21:15 +0200)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index a658986593a6be4e3c87890e52c53839965c225e..fdeb59977c9b75196eb52f84f6742a17a7020f65 100644 (file)
@@ -117,6 +117,13 @@ config BR2_PACKAGE_MESA3D_DRI_DRIVER_RADEON
 
 endif # BR2_PACKAGE_XORG7
 
+comment "Off-screen Rendering"
+
+config BR2_PACKAGE_MESA3D_OSMESA
+       bool "OSMesa library"
+       help
+         The OSMesa API provides functions for making off-screen renderings.
+
 if BR2_PACKAGE_MESA3D_DRIVER
 
 comment "Additional API Support"
index 84ad25efbafac3342e69cd702c595c206bf382c3..8097575ad32c8041277306ab88d0ac92ba3c1a20 100644 (file)
@@ -110,6 +110,12 @@ endif
 
 # APIs
 
+ifeq ($(BR2_PACKAGE_MESA3D_OSMESA),y)
+MESA3D_CONF_OPTS += --enable-osmesa
+else
+MESA3D_CONF_OPTS += --disable-osmesa
+endif
+
 # Always enable OpenGL:
 #   - it is needed for GLES (mesa3d's ./configure is a bit weird)
 #   - but if no DRI driver is enabled, then libgl is not built,