libssh2: fix link with libgcrypt
authorBaruch Siach <baruch@tkos.co.il>
Sun, 9 Jul 2017 19:05:24 +0000 (22:05 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 9 Jul 2017 21:10:22 +0000 (23:10 +0200)
libssh2 uses the implicit 'yes' argument of the --with-libgcrypt parameter as
a library path prefix, which breaks the build. Pass the library path as
--with-libgcrypt argument to fix that. Drop the unneeded
--with-libgcrypt-prefix.

Fixes:
http://autobuild.buildroot.net/results/ac3/ac3a3f5871a6c20f5407a468809682ce491b9cb3/
http://autobuild.buildroot.net/results/ba3/ba31fa11b2ce2875649414dd9093e039dfc129e8/
http://autobuild.buildroot.net/results/b07/b07bbbf7fe164ba6dc435de6d8b41fadff7a3b08/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libssh2/libssh2.mk

index ab721ac2dc87ad313ed11c9d60d823a651fe3d6e..c658282349be95dd617fe7c344681d2dcc4b6b1d 100644 (file)
@@ -15,8 +15,7 @@ LIBSSH2_CONF_OPTS = --disable-examples-build
 # Favour libgcrypt.
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 LIBSSH2_DEPENDENCIES += libgcrypt
-LIBSSH2_CONF_OPTS += --with-libgcrypt \
-       --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
+LIBSSH2_CONF_OPTS += --with-libgcrypt=$(STAGING_DIR)/usr \
        --without-openssl
 # configure.ac forgets to link to dependent libraries of gcrypt breaking static
 # linking