ruby: disable fiddle support for bfin
authorPeter Seiderer <ps.report@gmx.net>
Thu, 23 Oct 2014 19:58:34 +0000 (21:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Oct 2014 09:07:01 +0000 (11:07 +0200)
Disable fiddle support because of compile failure (no ffi_closure support
for bfin).

Fixes:
 http://autobuild.buildroot.net/results/0a8/0a854274b520d4daca3911a64777a447b5756a52/

[Thomas: slightly adjust the comment wording.]

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ruby/ruby.mk

index 34da13d64ad19571eca9d93a0e64fe4ce473618a..e633ee44f90f358a24ffab1c0bfb1f424ba12f00 100644 (file)
@@ -30,6 +30,9 @@ RUBY_CONF_ENV = CFLAGS="$(RUBY_CFLAGS)"
 
 ifeq ($(BR2_bfin),y)
 RUBY_CONF_ENV = ac_cv_func_dl_iterate_phdr=no
+# Blackfin doesn't have FFI closure support, needed by the fiddle
+# extension.
+RUBY_CONF_OPTS += --with-out-ext=fiddle
 endif
 
 # Force optionals to build before we do