projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0fc78cb
)
openssl: enable aarch64 optimization
author
Matthew Shyu
<matthew.shyu@amlogic.com>
Tue, 19 Apr 2016 10:26:46 +0000
(18:26 +0800)
committer
Peter Korsgaard
<peter@korsgaard.com>
Wed, 20 Apr 2016 06:59:32 +0000
(08:59 +0200)
Signed-off-by: Matthew Shyu <matthew.shyu@amlogic.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openssl/openssl.mk
patch
|
blob
|
history
diff --git
a/package/openssl/openssl.mk
b/package/openssl/openssl.mk
index 3b8e52563ace39525c2868a624800371a81ef4a5..2f50dfb1faee2cf76daac3772f39cacd940bc485 100644
(file)
--- a/
package/openssl/openssl.mk
+++ b/
package/openssl/openssl.mk
@@
-37,6
+37,9
@@
endif
ifeq ($(ARCH),arm)
OPENSSL_TARGET_ARCH = armv4
endif
+ifeq ($(ARCH),aarch64)
+OPENSSL_TARGET_ARCH = aarch64
+endif
ifeq ($(ARCH),powerpc)
# 4xx cores seem to have trouble with openssl's ASM optimizations
ifeq ($(BR2_powerpc_401)$(BR2_powerpc_403)$(BR2_powerpc_405)$(BR2_powerpc_405fp)$(BR2_powerpc_440)$(BR2_powerpc_440fp),)