proftpd: add mod_redis support
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 12 Apr 2017 10:56:19 +0000 (11:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 12 Apr 2017 19:59:35 +0000 (21:59 +0200)
The mod_redis module enables ProFTPD support for caching data in Redis
servers, using the hiredis client library. This is available since
proftpd-1.3.6rc5 and later.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/proftpd/Config.in
package/proftpd/proftpd.mk

index dd87eb45aa97c2b583f049ba946da3486f2de0e3..07a5d86cc6185f9fe47e80567e0695d1d451a014 100644 (file)
@@ -13,4 +13,11 @@ config BR2_PACKAGE_PROFTPD_MOD_REWRITE
        help
          Compile ProFTPD with mod_rewrite support
 
+config BR2_PACKAGE_PROFTPD_MOD_REDIS
+       bool "mod_redis support"
+       select BR2_PACKAGE_HIREDIS
+       help
+         The mod_redis module enables ProFTPD support for caching data in Redis
+         servers, using the hiredis client library.
+
 endif
index 5f42408213d8b8dc4abfa96cf681513d80e97f60..3e165c6adabff4a1b06728848a48fdad38d6ba18 100644 (file)
@@ -27,6 +27,13 @@ ifeq ($(BR2_PACKAGE_PROFTPD_MOD_REWRITE),y)
 PROFTPD_CONF_OPTS += --with-modules=mod_rewrite
 endif
 
+ifeq ($(BR2_PACKAGE_PROFTPD_MOD_REDIS),y)
+PROFTPD_CONF_OPTS += --enable-redis
+PROFTPD_DEPENDENCIES += hiredis
+else
+PROFTPD_CONF_OPTS += --disable-redis
+endif
+
 # configure script doesn't handle detection of %llu format string
 # support for printing the file size when cross compiling, breaking
 # access for large files.