toolchain-buildroot: make sure glibc isn't chosen when BR2_PREFER_STATIC_LIB=y
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 11 Nov 2013 17:57:31 +0000 (18:57 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 11 Nov 2013 21:29:16 +0000 (22:29 +0100)
(e)glibc doesn't support a fully statically linked userspace. Even a
basic program such as Busybox fails to do authentication due to glibc
loading some libraries dynamically. Therefore, we disable the
possibility of building a glibc toolchain when
BR2_PREFER_STATIC_LIB=y.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/toolchain-buildroot/Config.in

index 5111c746f9c69d0259f0ccf3ad288f29bafd056b..8b37127d492c5ad54da60ce76ac74b31fc4bc834 100644 (file)
@@ -23,6 +23,7 @@ config BR2_TOOLCHAIN_BUILDROOT_EGLIBC
                   BR2_sh     || BR2_sh64     || BR2_sparc   || \
                   BR2_x86_64
        depends on BR2_USE_MMU
+       depends on !BR2_PREFER_STATIC_LIB
        select BR2_TOOLCHAIN_USES_GLIBC
        # our eglibc.mk enables RPC support
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
@@ -43,6 +44,7 @@ config BR2_TOOLCHAIN_BUILDROOT_GLIBC
                   BR2_sh     || BR2_sh64     || BR2_sparc   || \
                   BR2_x86_64
        select BR2_TOOLCHAIN_USES_GLIBC
+       depends on !BR2_PREFER_STATIC_LIB
        # our glibc.mk enables RPC support
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
        help
@@ -54,6 +56,9 @@ config BR2_TOOLCHAIN_BUILDROOT_GLIBC
 
          http://www.gnu.org/software/libc/
 
+comment "(e)glibc only available with shared lib support"
+       depends on BR2_PREFER_STATIC_LIB
+
 endchoice
 
 config BR2_TOOLCHAIN_BUILDROOT_LIBC