dbus: fix host-dbus build
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 15 Dec 2009 22:42:57 +0000 (23:42 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 15 Dec 2009 22:42:57 +0000 (23:42 +0100)
Use correct variable name for the host source directory for
DBUS_HOST_INTROSPECT, and use late binding as HOST_DBUS_DIR only gets
defined later on (by AUTOTARGETS).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dbus/dbus.mk

index ae65b7da0874dfd6144aaa9962fe4ac3f2e5bd42..63f3caa98f514f38dfbac1d73247ea003cb0987b 100644 (file)
@@ -64,7 +64,7 @@ HOST_DBUS_CONF_OPT = \
                --with-xml=expat
 
 # dbus for the host
-DBUS_HOST_INTROSPECT:=$(DBUS_HOST_DIR)/introspect.xml
+DBUS_HOST_INTROSPECT=$(HOST_DBUS_DIR)/introspect.xml
 
 HOST_DBUS_GEN_INTROSPECT = \
        $(HOST_DIR)/usr/bin/dbus-daemon --introspect > $(DBUS_HOST_INTROSPECT)