libevent: add optional dependency on OpenSSL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Jan 2015 11:39:56 +0000 (12:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Jan 2015 15:37:48 +0000 (16:37 +0100)
libevent can optionally use OpenSSL, so add an optional dependency on
this package to explicit this possibility. This makes sure libevent
always gets built with OpenSSL support when the OpenSSL package is
enabled.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/libevent/libevent.mk

index 607b7b2150b33bc1938153be0a11012ef2b742f8..30fcb5ac301946d9d36b78371d7d38a73412dbe3 100644 (file)
@@ -22,5 +22,12 @@ ifneq ($(BR2_PACKAGE_PYTHON),y)
 LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBEVENT_DEPENDENCIES += openssl
+LIBEVENT_CONF_OPTS += --enable-openssl
+else
+LIBEVENT_CONF_OPTS += --disable-openssl
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))