toolchain/gcc: remove unused gcc 3.x cruft from 4.x makefile (sysroot)
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Jan 2009 13:34:35 +0000 (13:34 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Jan 2009 13:34:35 +0000 (13:34 -0000)
toolchain/gcc/gcc-uclibc-4.x.mk

index 118b257e04f033bdf3806bb3ef58732f13818661..d0d3ae31688119ec47fab9b052eb18423ce1f404 100644 (file)
@@ -56,9 +56,6 @@ GCC_CAT:=$(BZCAT)
 GCC_STRIP_HOST_BINARIES:=nope
 GCC_SRC_DIR:=$(GCC_DIR)
 
-ifeq ($(findstring x3.,x$(GCC_VERSION)),x3.)
-GCC_NO_MPFR:=y
-endif
 ifeq ($(findstring x4.0.,x$(GCC_VERSION)),x4.0.)
 GCC_NO_MPFR:=y
 endif
@@ -335,27 +332,7 @@ endif
                        $(GNU_TARGET_NAME)$${app##$(REAL_GNU_TARGET_NAME)}; \
                done; \
        )
-       #
-       # Now for the ugly 3.3.x soft float hack...
-       #
-ifeq ($(BR2_SOFT_FLOAT),y)
-ifeq ($(findstring x3.3.,x$(GCC_VERSION)),x3.3.)
-       # Make sure we have a soft float specs file for this arch
-       if [ ! -f toolchain/gcc/$(GCC_VERSION)/specs-$(ARCH)-soft-float ]; then \
-               echo soft float configured but no specs file for this arch; \
-               /bin/false; \
-       fi
-       # Replace specs file with one that defaults to soft float mode.
-       if [ ! -f $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ]; then \
-               echo staging dir specs file is missing; \
-               /bin/false; \
-       fi
-       cp toolchain/gcc/$(GCC_VERSION)/specs-$(ARCH)-soft-float $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
-endif
-endif
-       #
-       # Ok... that's enough of that.
-       #
+
        mkdir -p $(TARGET_DIR)/usr/lib $(TARGET_DIR)/usr/sbin
        touch $@
 
@@ -456,11 +433,7 @@ $(GCC_BUILD_DIR3)/.compiled: $(GCC_BUILD_DIR3)/.configured
 #
 # gcc-lib dir changes names to gcc with 3.4.mumble
 #
-ifeq ($(findstring x3.4.,x$(GCC_VERSION)),x3.4.)
-GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
-else
 GCC_LIB_SUBDIR=lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
-endif
 # sigh... we need to find a better way
 ifeq ($(findstring x4.0.,x$(GCC_VERSION)),x4.0.)
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
@@ -487,20 +460,7 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
                $(MAKE1) -C $(GCC_BUILD_DIR3) install
        # Remove broken specs file (cross compile flag is set).
        rm -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/specs
-       #
-       # Now for the ugly 3.3.x soft float hack...
-       #
-ifeq ($(BR2_SOFT_FLOAT),y)
-ifeq ($(findstring x3.3.,x$(GCC_VERSION)),x3.3.)
-       # Add a specs file that defaults to soft float mode.
-       cp toolchain/gcc/$(GCC_VERSION)/specs-$(ARCH)-soft-float $(TARGET_DIR)/usr/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
-       # Make sure gcc does not think we are cross compiling
-       $(SED) "s/^1/0/;" $(TARGET_DIR)/usr/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
-endif
-endif
-       #
-       # Ok... that's enough of that.
-       #
+
        -(cd $(TARGET_DIR)/bin && find -type f | xargs $(STRIPCMD) > /dev/null 2>&1)
        -(cd $(TARGET_DIR)/usr/bin && find -type f | xargs $(STRIPCMD) > /dev/null 2>&1)
        -(cd $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR) && $(STRIPCMD) cc1 cc1plus collect2 > /dev/null 2>&1)