target gcc: cleanup
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 31 Dec 2010 11:39:06 +0000 (08:39 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Jan 2011 21:55:37 +0000 (22:55 +0100)
WITH_TARGET_{GMP/MPC/MPFR} is unneeded since we are providing a sysroot.

It also breaks build-gcc under certain conditions.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/gcc/gcc-uclibc-4.x.mk

index 633b8aae875f3c3e4e0989a842cfbd9e5b4d5de8..80bed5eff4e3b8e1588657f5d11bdf1fd3af1663 100644 (file)
@@ -119,11 +119,8 @@ GCC_HOST_PREREQ += host-mpc
 endif
 
 GCC_TARGET_PREREQ += mpfr gmp
-GCC_WITH_TARGET_GMP = --with-gmp=$(STAGING_DIR)/usr
-GCC_WITH_TARGET_MPFR = --with-mpfr=$(STAGING_DIR)/usr
 ifeq ($(findstring x4.5.,x$(GCC_VERSION)),x4.5.)
 GCC_TARGET_PREREQ += mpc
-GCC_WITH_TARGET_MPC = --with-mpc=$(STAGING_DIR)/usr
 endif
 
 ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
@@ -506,9 +503,6 @@ $(GCC_BUILD_DIR4)/.configured: $(GCC_BUILD_DIR4)/.prepared
                --disable-multilib \
                $(GCC_TLS) \
                $(GCC_SHARED_LIBGCC) \
-               $(GCC_WITH_TARGET_GMP) \
-               $(GCC_WITH_TARGET_MPFR) \
-               $(GCC_WITH_TARGET_MPC) \
                $(DISABLE_NLS) \
                $(THREADS) \
                $(GCC_DECIMAL_FLOAT) \