fmt: new package
authorSemyon Kolganov <semenak94@mail.ru>
Thu, 6 Apr 2017 15:41:17 +0000 (18:41 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 Apr 2017 20:14:48 +0000 (22:14 +0200)
Signed-off-by: Semyon Kolganov <semenak94@mail.ru>
[Thomas:
 - add entry to DEVELOPERS file
 - add missing wchar dependency
 - minor tweaks.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/fmt/Config.in [new file with mode: 0644]
package/fmt/fmt.hash [new file with mode: 0755]
package/fmt/fmt.mk [new file with mode: 0755]

index e1713cf4c39d441256a88dcc0aa7395a3a818ec1..629ea4bbaa07e5abd8af95b70a0881b30289f320 100644 (file)
@@ -1411,6 +1411,9 @@ F:        package/kyua/
 F:     package/lutok/
 F:     package/yaml-cpp/
 
+N:     Semyon Kolganov <semenak94@mail.ru>
+F:     package/fmt/
+
 N:     Sergio Prado <sergio.prado@e-labworks.com>
 F:     package/libgdiplus/
 F:     package/mongodb/
index fe4c0ae4bc5c68716c38ce0d6ee65f48592bf55d..a4855a9e4276b482f8f46c276e312967017735bb 100644 (file)
@@ -1433,6 +1433,7 @@ endmenu
 menu "Text and terminal handling"
        source "package/augeas/Config.in"
        source "package/enchant/Config.in"
+       source "package/fmt/Config.in"
        source "package/icu/Config.in"
        source "package/libcli/Config.in"
        source "package/libedit/Config.in"
diff --git a/package/fmt/Config.in b/package/fmt/Config.in
new file mode 100644 (file)
index 0000000..979d940
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_FMT
+       bool "fmt"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_USE_WCHAR
+       help
+         fmt is an open-source formatting library for C++. It can be used
+         as a safe alternative to printf or as a fast alternative to
+         IOStreams.
+
+comment "fmt needs a toolchain w/ C++, wchar"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR
diff --git a/package/fmt/fmt.hash b/package/fmt/fmt.hash
new file mode 100755 (executable)
index 0000000..beb120b
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 dce62ab75a161dd4353a98364feb166d35e7eea382169d59d9ce842c49c55bad fmt-3.0.1.tar.gz
diff --git a/package/fmt/fmt.mk b/package/fmt/fmt.mk
new file mode 100755 (executable)
index 0000000..b7e3db0
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# fmt
+#
+################################################################################
+
+FMT_VERSION = 3.0.1
+FMT_SITE = $(call github,fmtlib,fmt,$(FMT_VERSION))
+FMT_LICENSE = BSD-2-Clause
+FMT_LICENSE_FILES = LICENSE.rst
+FMT_INSTALL_STAGING = YES
+
+FMT_CONF_OPTS = \
+       -DHAVE_OPEN=ON \
+       -DFMT_INSTALL=ON \
+       -DFMT_TEST=OFF
+
+$(eval $(cmake-package))