infra/pkg-kconfig: fix saving the config file
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 20 Oct 2014 20:23:36 +0000 (22:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Oct 2014 20:49:42 +0000 (22:49 +0200)
When saving (aka updating) the configuration file of a kconfig package,
a subsequent call to "make" would rebuild the package, even though the
configuration did not actually change.

It took quite a while to understand why. But the reason is so simple and
obvious, when you think about it:

  - $(@D)/.config depends on the config file $(BUSYBOX_CONFIG_FILE)
  - busybox-update-config then copies $(@D)/.config back to the config
    file $(BUSYBOX_CONFIG_FILE)
  - so the config file is newer than $(@D)/.config

So, in the next run, pkg-kconfig believes that it has to rebuild
busybox. Bummer... :-/

So, the fix is very trivial, and just requires asking "cp" to preserve
timestamps, so the dependency does not kick in at the next run.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-kconfig.mk

index 071153a0bfc33b8f41f18df4006a53d60863068a..ec58d69f55ee181e937d39e778d19b6da74179ed 100644 (file)
@@ -66,7 +66,7 @@ $$(addprefix $(1)-,$$($(2)_KCONFIG_EDITORS)): $$($(2)_DIR)/.stamp_kconfig_fixup_
 
 # Target to copy back the configuration to the source configuration file
 $(1)-update-config: $$($(2)_DIR)/.stamp_kconfig_fixup_done
-       cp -f $$($(2)_DIR)/.config $$($(2)_KCONFIG_FILE)
+       cp --preserve=timestamps -f $$($(2)_DIR)/.config $$($(2)_KCONFIG_FILE)
 
 endef # inner-kconfig-package