package/sconeserver: unconditionally needs host-pkgconf
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 28 Aug 2016 18:19:53 +0000 (20:19 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Aug 2016 22:04:03 +0000 (00:04 +0200)
sconeserver uses pkg-config macros and uses autoreconf, so it
unconditionally needs host-pkgconf.

[Peter: drop host-pkgconf from sub options, update description]
Reported-by: Matthew Weber <matt@thewebers.ws>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sconeserver/sconeserver.mk

index e02c1a66f7406a5be554000ce9c09e18c1620c65..793ca6fb261ff1fd484ee8a6c9ca1ba7ecdf1391 100644 (file)
@@ -10,7 +10,7 @@ SCONESERVER_LICENSE = GPLv2+
 SCONESERVER_LICENSE_FILES = COPYING
 # fetching from Git, we need to generate the configure script
 SCONESERVER_AUTORECONF = YES
-SCONESERVER_DEPENDENCIES += pcre
+SCONESERVER_DEPENDENCIES = host-pkgconf pcre
 # disable markdown module because its git submodule cmark
 # https://github.com/sconemad/sconeserver/tree/master/markdown
 # has no cross-compile support provided by the sconeserver build system
@@ -46,7 +46,7 @@ SCONESERVER_CONF_OPTS += --without-sconesite
 endif
 
 ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
-SCONESERVER_DEPENDENCIES += imagemagick host-pkgconf
+SCONESERVER_DEPENDENCIES += imagemagick
 SCONESERVER_CONF_OPTS += \
        --with-sconesite-image \
        --with-Magick++-config="$(STAGING_DIR)/usr/bin/Magick++-config"
@@ -79,7 +79,7 @@ SCONESERVER_CONF_OPTS += --without-rss
 endif
 
 ifeq ($(BR2_PACKAGE_SCONESERVER_LOCATION),y)
-SCONESERVER_DEPENDENCIES += host-pkgconf gpsd
+SCONESERVER_DEPENDENCIES += gpsd
 SCONESERVER_CONF_OPTS += --with-location
 else
 SCONESERVER_CONF_OPTS += --without-location