docs/manual: update cmake-package infrastructure section
authorSamuel Martin <s.martin49@gmail.com>
Sun, 19 Oct 2014 18:04:51 +0000 (20:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Oct 2014 16:06:29 +0000 (17:06 +0100)
This patch documents the CMake options preset by the cmake-package
infrastructure.

[Thomas: minor wording tweak.]

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
docs/manual/adding-packages-cmake.txt

index d5a70293f00e959004cc4582647395885f4aafd7..02f1dbbb0fa44aa1f65adbf2c1f2e1c123d4278b 100644 (file)
@@ -95,7 +95,17 @@ typical packages will therefore only use a few of them.
   pass to CMake. By default, empty.
 
 * +LIBFOO_CONF_OPTS+, to specify additional configure options to pass
-  to CMake. By default, empty.
+  to CMake. By default, empty. A number of common CMake options are
+  set by the +cmake-package+ infrastructure; so it is normally not
+  necessary to set them in the package's +*.mk+ file unless you want
+  to override them:
+
+** +CMAKE_BUILD_TYPE+ is driven by +BR2_ENABLE_DEBUG+;
+** +CMAKE_INSTALL_PREFIX+;
+** +BUILD_SHARED_LIBS+ is driven by +BR2_PREFER_STATIC_LIBS+;
+** +BUILD_DOC+, +BUILD_DOCS+ are disabled;
+** +BUILD_EXAMPLE+, +BUILD_EXAMPLES+ are disabled;
+** +BUILD_TEST+, +BUILD_TESTS+, +BUILD_TESTING+ are disabled.
 
 * +LIBFOO_MAKE+, to specify an alternate +make+ command. This is
   typically useful when parallel make is enabled in the configuration