Makefile: compute the version string for all to use
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Sun, 31 Oct 2010 16:35:12 +0000 (17:35 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 3 Nov 2010 22:31:04 +0000 (23:31 +0100)
Some packages use the buildroot version string (to set their own version
string). Computing the version string globally will makes it easy for
them to use it instead of re-computing it in every packages.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 8d53778b30bbc7ce21ec264cf1e46baa1ee9d09e..d6a76282d36fa4651ae947cb187eaf157659d6e6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -35,6 +35,10 @@ CONFIG_CONFIG_IN=Config.in
 CONFIG=package/config
 DATE:=$(shell date +%Y%m%d)
 
+# Compute the full local version string so packages can use it as-is
+# Need to export it, so it can be got from environment in children (eg. mconf)
+export BR2_VERSION_FULL:=$(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion)
+
 noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
        defconfig %_defconfig savedefconfig allyesconfig allnoconfig silentoldconfig release \
        randpackageconfig allyespackageconfig allnopackageconfig \