- provide a "source-check" target that tries to download all packages with
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Thu, 7 Jun 2007 12:57:03 +0000 (12:57 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Thu, 7 Jun 2007 12:57:03 +0000 (12:57 -0000)
  wget's spider-mode (i.e. just see if the server says the file is there without
  actually downloading the files.
  Convenient to check for unavailable source-packages.

Makefile

index dff5fbf8ec3d84d46642555fbce12f6a66918019..e3c18cacacb66056c2501a398bf93f2e69b95260 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -28,6 +28,7 @@ CONFIG = package/config
 
 noconfig_targets := menuconfig config oldconfig randconfig \
        defconfig allyesconfig allnoconfig release tags    \
+       source-check
 
 #      $(shell find . -name *_defconfig |sed 's/.*\///')
 
@@ -156,6 +157,13 @@ $(TARGET_DIR):
 
 source: $(TARGETS_SOURCE) $(HOST_SOURCE)
 
+.config.check: dependencies
+       $(SED) '/BR2_WGET/s/\"$$/ --spider\"/g' .config
+       touch $@
+
+_source-check: .config.check
+       $(MAKE) source
+
 #############################################################
 #
 # Cleanup and misc junk
@@ -214,9 +222,9 @@ randconfig: $(CONFIG)/conf
        @$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
 
 allyesconfig: $(CONFIG)/conf
-       #@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
+       cp $(CONFIG_DEFCONFIG) .config
+       @$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
        #sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
-       @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
 
 allnoconfig: $(CONFIG)/conf
        @$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
@@ -228,6 +236,10 @@ defconfig: $(CONFIG)/conf
        cp $(shell find . -name $@) .config
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
 
+# check if download URLs are outdated 
+source-check: allyesconfig
+       $(MAKE) _source-check
+
 #############################################################
 #
 # Cleanup and misc junk