Switch to the C locale before greping for an english text.
authorRobert Griebl <griebl@gmx.de>
Sat, 13 Mar 2004 00:01:08 +0000 (00:01 -0000)
committerRobert Griebl <griebl@gmx.de>
Sat, 13 Mar 2004 00:01:08 +0000 (00:01 -0000)
make/ext2root.mk

index 5171ac2ed0aa16867e3dd77c5b049007aa40241e..0c66c18a9a0c79fa9b79134ee84d6e6a5e4af5b6 100644 (file)
@@ -34,7 +34,7 @@ genext2fs: $(GENEXT2_DIR)/genext2fs
 # How much KB we want to add to the calculated size for slack space
 #GENEXT2_ADDTOROOTSIZE=4096
 GENEXT2_ADDTOROOTSIZE=16384
-GENEXT2_REALSIZE=$(subst total,, $(shell du $(TARGET_DIR) -s -c -k | grep total )) 
+GENEXT2_REALSIZE=$(subst total,, $(shell LANG=C du $(TARGET_DIR) -s -c -k | grep total )) 
 GENEXT2_SIZE=$(shell expr $(GENEXT2_REALSIZE) + $(GENEXT2_ADDTOROOTSIZE))
 # We currently add about 400 device nodes, so add that into the total
 GENEXT2_INODES=$(shell expr $(shell find $(TARGET_DIR) | wc -l) + 400)