pkg-generic: make PKG_DL_DIR equal to DL_DIR
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tue, 4 Jul 2017 16:22:02 +0000 (18:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Jul 2017 21:36:47 +0000 (23:36 +0200)
This variable is currently not used by anyone.
The value is changed to match the path to DL_DIR.

The next patch will introduce the use of PKG_DL_DIR for packages that
use specific EXTRACT_CMDS.

And then we will be able to change the value of PKG_DL_DIR to create a
new directory structure in DL_DIR with a subdirectory for each package.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index b2b3af7d8f0191286c964447da38451bd2c9ed27..130fd67560996ecf0fe7a902f7cfd61cbc080bce 100644 (file)
@@ -434,7 +434,7 @@ endif
 
 $(2)_BASE_NAME = $$(if $$($(2)_VERSION),$(1)-$$($(2)_VERSION),$(1))
 $(2)_RAW_BASE_NAME = $$(if $$($(2)_VERSION),$$($(2)_RAWNAME)-$$($(2)_VERSION),$$($(2)_RAWNAME))
-$(2)_DL_DIR    =  $$(DL_DIR)/$$($(2)_BASE_NAME)
+$(2)_DL_DIR    =  $$(DL_DIR)
 $(2)_DIR       =  $$(BUILD_DIR)/$$($(2)_BASE_NAME)
 
 ifndef $(2)_SUBDIR