tpm2-abrmd: fix build with BR2_FORTIFY_SOURCE_1
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 15 Jan 2019 10:15:20 +0000 (11:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 16 Jan 2019 13:25:05 +0000 (14:25 +0100)
The configure script passes -U FORTIFY_SOURCE -D FORTIFY_SOURCE=2 by
default, which conflicts with BR2_FORTIFY_SOURCE_1 as -Werror is used:

<cross>-gcc ..  -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 .. -D_FORTIFY_SOURCE=1
<command-line>:0:0: error: "_FORTIFY_SOURCE" redefined [-Werror]

Disable this so the FORTIFY_SOURCE flags in TARGET_CFLAGS (if any) is used
instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tpm2-abrmd/tpm2-abrmd.mk

index 2834615ac3585d5daab92fc84382eac0fc7f8a31..31f19f5d01a724ae1313dc79ea0379365dabc854 100644 (file)
@@ -11,10 +11,13 @@ TPM2_ABRMD_LICENSE_FILES = LICENSE
 TPM2_ABRMD_INSTALL_STAGING = YES
 TPM2_ABRMD_DEPENDENCIES = dbus libglib2 tpm2-tss host-pkgconf
 
-# -fstack-protector-all is used by default. Disable that so the
-# BR2_SSP_* options in the toolchain wrapper are used instead
+# -fstack-protector-all and FORTIFY_SOURCE=2 is used by
+# default. Disable that so the BR2_SSP_* / BR2_FORTIFY_SOURCE_* options
+# in the toolchain wrapper and CFLAGS are used instead
 TPM2_ABRMD_CONF_ENV = \
-       ax_cv_check_cflags___________Werror_______fstack_protector_all=no
+       ax_cv_check_cflags___________Werror_______fstack_protector_all=no \
+       ax_cv_check_ccppflags___________Werror_______U_FORTIFY_SOURCE=no \
+       ax_cv_check_ccppflags___________Werror_______D_FORTIFY_SOURCE_2=no
 
 TPM2_ABRMD_CONF_OPTS += \
        --with-systemdsystemunitdir=$(if $(BR2_INIT_SYSTEMD),/usr/lib/systemd/system,no) \