pciutils: work around race condition in make install with high BR2_JLEVEL
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 17 Dec 2012 08:27:30 +0000 (09:27 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 17 Dec 2012 08:27:30 +0000 (09:27 +0100)
Fixes http://autobuild.buildroot.net/results/908d7368c8dc8e320fd33f3193039f5925adc352

make install and install-lib can race against eachother causing 'install'
to fail. Work around it using MAKE1.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pciutils/pciutils.mk

index ba866a00a9b199d0ce801bf68506aae238c85211..6219711fffb2bbccf9384d625139b2c814bf810a 100644 (file)
@@ -48,12 +48,12 @@ endef
 
 # Ditch install-lib if SHARED is an option in the future
 define PCIUTILS_INSTALL_TARGET_CMDS
-       $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
+       $(MAKE1) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
                SHARED=$(PCIUTILS_SHARED) install install-lib
 endef
 
 define PCIUTILS_INSTALL_STAGING_CMDS
-       $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
+       $(MAKE1) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
                SHARED=$(PCIUTILS_SHARED) install install-lib
 endef