Update php package to 5.2.11
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 9 Oct 2009 13:31:31 +0000 (10:31 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 13:38:41 +0000 (15:38 +0200)
Security Enhancements and Fixes in PHP 5.2.11:

   * Fixed certificate validation inside php_openssl_apply_verification_policy
   * Fixed sanity check for the color index in imagecolortransparent()
   * Added missing sanity checks around exif processing
   * Fixed bug #44683 (popen crashes when an invalid mode is passed)

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/php/php.mk

diff --git a/CHANGES b/CHANGES
index 13fa44b7852546d4d47ae6dbddf7d034ca96dd82..d12e3a87ce6bf24c9d0d75e2de5a913836d1eabe 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -7,8 +7,8 @@
        e2fsprogs, festival, gstreamer, gst-plugins-bad, gst-plugins-base,
        gst-plugins-good, imagemagick, iptables, kernel-headers, kismet,
        libevent, libglib2, liblockfile, libmad, libupnp, libuuid, ltrace,
-       lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl, python,
-       quagga, radvd, rsync, samba, shared-mime-info, speech-tools,
+       lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl, php,
+       python, quagga, radvd, rsync, samba, shared-mime-info, speech-tools,
        squashfs, syslinux, u-boot, util-linux, valgrind, vsftpd, wipe,
        wpa-supplicant, xdata_xcursor-themes, zlib
 
@@ -27,6 +27,7 @@
        #615: python: Don't delete .py files unless asked
        #617: netkit/inetd requires RPC and fails to build if RPC is disabled
        #619: netkittelnet requires netkitbase to install, but there's no dependency
+       #653: [SECURITY] Update php package to version 5.2.11
 
 2009.08, Released August 31th, 2009:
 
index 1f4c7d129fd5ef641f7f7530d3c0f10d9575f63f..2668774d3198ca6eef6b3955ff57f9485d159142 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-PHP_VERSION = 5.2.10
+PHP_VERSION = 5.2.11
 PHP_SOURCE = php-$(PHP_VERSION).tar.bz2
 PHP_SITE = http://www.php.net/distributions
 PHP_INSTALL_STAGING = YES