package/dovecot: add optional support for lz4
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 10 Feb 2016 20:58:19 +0000 (21:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 16 Feb 2016 22:07:01 +0000 (23:07 +0100)
When lz4 was compiled before, dovecot will use it as optional dependency:

$ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/lib/dovecot/lib30_imap_zlib_plugin.so | grep NEEDED
 0x00000001 (NEEDED)                     Shared library: [libz.so.1]
 0x00000001 (NEEDED)                     Shared library: [liblzma.so.5]
 0x00000001 (NEEDED)                     Shared library: [liblz4.so.1]
 0x00000001 (NEEDED)                     Shared library: [libc.so.1]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dovecot/dovecot.mk

index dbf2dab10660a0dbc45f3c7eb2fcdf3054bcf64e..6b69329054a1fffbd081534922712a325dc96509 100644 (file)
@@ -76,6 +76,13 @@ else
 DOVECOT_CONF_OPTS += --without-sqlite
 endif
 
+ifeq ($(BR2_PACKAGE_LZ4),y)
+DOVECOT_CONF_OPTS += --with-lz4
+DOVECOT_DEPENDENCIES += lz4
+else
+DOVECOT_CONF_OPTS += --without-lz4
+endif
+
 ifeq ($(BR2_PACKAGE_XZ),y)
 DOVECOT_CONF_OPTS += --with-lzma
 DOVECOT_DEPENDENCIES += xz