external toolchain: respect $(Q)
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 06:48:35 +0000 (08:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 06:48:35 +0000 (08:48 +0200)
Use $(Q) in external toolchain support so that the user can get the
full output by passing V=1 to make, and still get a nice and clean
output by default.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/external-toolchain/ext-tool.mk

index e772cda7ea217407cd8328326e63623f78b44175..c9692a1abbe8d86914aa419faf86991612030be6 100644 (file)
@@ -203,18 +203,18 @@ ifeq ($(strip $(SYSROOT_DIR)),)
        exit 1
 endif
 ifeq ($(BR2_arm),y)
-       @$(call check_arm_abi)
+       $(Q)$(call check_arm_abi)
 endif
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
-       @$(call check_uclibc,$(SYSROOT_DIR))
+       $(Q)$(call check_uclibc,$(SYSROOT_DIR))
 else
-       @$(call check_glibc,$(SYSROOT_DIR))
+       $(Q)$(call check_glibc,$(SYSROOT_DIR))
 endif
        mkdir -p $(TARGET_DIR)/lib
        @echo "Copy external toolchain libraries to target..."
-       @for libs in $(EXTERNAL_LIBS); do \
+       $(Q)for libs in $(EXTERNAL_LIBS); do \
                $(call copy_toolchain_lib_root,$(SYSROOT_DIR),$$libs,/lib,$(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
        done
        @echo "Copy external toolchain sysroot to staging..."
-       @$(call copy_toolchain_sysroot,$(SYSROOT_DIR))
+       $(Q)$(call copy_toolchain_sysroot,$(SYSROOT_DIR))
        @touch $@