webp: minor improvements
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jun 2016 12:25:42 +0000 (14:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jun 2016 12:25:42 +0000 (14:25 +0200)
Following commit e47638f8dca29b0d9b729edbaeaa11a08f9957fa, this commit
makes a few additional cosmetic improvements to the webp package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/webp/Config.in
package/webp/webp.mk

index 7c4722fbed367ca599267443456ea8d1838e73eb..646eb9ef5a1edde2f0ea8aa8e7e82cd451eb58b6 100644 (file)
@@ -6,10 +6,13 @@ config BR2_PACKAGE_WEBP
 
          https://developers.google.com/speed/webp/
 
+if BR2_PACKAGE_WEBP
+
 config BR2_PACKAGE_WEBP_DEMUX
        bool "webpdemux"
-       depends on BR2_PACKAGE_WEBP
        help
-         "Demux" is a part of WebPMux for extraction and manipulation of an
-         extended format WebP file, which can have features like color profile,
-         metadata and animation.
+         Demux is a part of WebPMux for extraction and manipulation
+         of an extended format WebP file, which can have features
+         like color profile, metadata and animation.
+
+endif
index b6090242ba4d00c2a74e1431b29e3c99c4b74ee5..8d9ca8f7d746f59f1ecdfe55fb1857d462b11ccb 100644 (file)
@@ -19,6 +19,8 @@ WEBP_CONF_OPTS += \
 
 ifeq ($(BR2_PACKAGE_WEBP_DEMUX),y)
 WEBP_CONF_OPTS += --enable-libwebpdemux
+else
+WEBP_CONF_OPTS += --disable-libwebpdemux
 endif
 
 ifeq ($(BR2_PACKAGE_LIBPNG),y)