ftop: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 29 Jun 2014 15:39:06 +0000 (12:39 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 30 Jun 2014 11:48:54 +0000 (13:48 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/ftop/Config.in [new file with mode: 0644]
package/ftop/ftop-0001-overflow.patch [new file with mode: 0644]
package/ftop/ftop.mk [new file with mode: 0644]

index d7e1acc04392d8eff651456ee2e643702d43850c..3f3b8d2139c2b7308dd511996f4c6ebe3f52aa73 100644 (file)
@@ -1118,6 +1118,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 endif
        source "package/cpuload/Config.in"
        source "package/dsp-tools/Config.in"
+       source "package/ftop/Config.in"
        source "package/htop/Config.in"
        source "package/iprutils/Config.in"
        source "package/keyutils/Config.in"
diff --git a/package/ftop/Config.in b/package/ftop/Config.in
new file mode 100644 (file)
index 0000000..878574f
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_FTOP
+       bool "ftop"
+       depends on BR2_LARGEFILE
+       select BR2_PACKAGE_NCURSES
+       help
+         Ftop is to files what top is to processes.
+         The progress of all open files and file systems can be monitored.
+
+         https://code.google.com/p/ftop/
+
+comment "ftop needs a toolchain w/ largefile"
+        depends on !BR2_LARGEFILE
diff --git a/package/ftop/ftop-0001-overflow.patch b/package/ftop/ftop-0001-overflow.patch
new file mode 100644 (file)
index 0000000..a3a27c3
--- /dev/null
@@ -0,0 +1,17 @@
+Set tmp_buf and rate_buf to something ridiculously high to fix a buffer
+overflow when COLUMNS is large. - JeR
+
+(Taken from gentoo portage)
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+--- a/src/ftop.c       2009-02-16 07:00:00.000000000 +0100
++++ b/src/ftop.c       2013-09-06 14:42:41.788852952 +0200
+@@ -736,7 +736,7 @@
+ {
+     size_t i, j, bytes, bar_total;
+     char more_procs_ch, more_files_ch, expanded_ch;
+-    char tmp_buf[80], rate_buf[80];
++    char tmp_buf[2048], rate_buf[2048];
+     char *tmp_str;
+     snapshot *s, *s_prev;
+     file_info *tmp_file;
diff --git a/package/ftop/ftop.mk b/package/ftop/ftop.mk
new file mode 100644 (file)
index 0000000..2220317
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# ftop
+#
+################################################################################
+
+FTOP_VERSION = 1.0
+FTOP_SITE = http://ftop.googlecode.com/files/
+FTOP_DEPENDENCIES = ncurses
+FTOP_LICENSE = GPLv3+
+FTOP_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))