Cleanup handling of gccbug script
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Mon, 3 Sep 2007 06:10:01 +0000 (06:10 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Mon, 3 Sep 2007 06:10:01 +0000 (06:10 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk
toolchain/gcc/gcc-uclibc-4.x.mk

index 1dff9ebedc749a683ae0cf2ab01630e358575694..a21e9a0ada4b72ed018cb033a0681d050309961f 100644 (file)
@@ -282,7 +282,7 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        fi
        # Strip the host binaries
 ifeq ($(GCC_STRIP_HOST_BINARIES),true)
-       -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/*
+       strip --strip-all -R .note -R .comment $(filter-out -gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
 endif
        # Make sure we have 'cc'.
        if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ]; then \
index a420c7fac0baba63e4859c6a5b7db23be3c5b850..c6f9df056a2c76ae29a2da263e66e03c63d0dbc6 100644 (file)
@@ -288,13 +288,9 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
                mv "$(STAGING_DIR)/lib64/"* "$(STAGING_DIR)/lib/"; \
                rmdir "$(STAGING_DIR)/lib64"; \
        fi
-       # Move gcc bug reporting script out of path of real executables
-       mv -f $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gccbug \
-               $(STAGING_DIR)/usr/bin/$(GNU_TARGET_NAME)-gccbug
        # Strip the host binaries
 ifeq ($(GCC_STRIP_HOST_BINARIES),true)
        strip --strip-all -R .note -R .comment $(filter-out -gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
-       -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/faked
 endif
        # Make sure we have 'cc'.
        if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ]; then \